+ Reply to Thread
Results 1 to 4 of 4

Thread: Weird problem with Authorize.net

  1. #1
    Client
    Join Date
    Nov 2009
    Posts
    46
    Squirrelcart version
    not specified!

    Weird problem with Authorize.net

    Hi,

    We have a client who has SC 3.3.1 installed at http://www.zanmonroe.com/cart/. They have a product for a seminar registration, priced at $750.

    When someone purchases that, everything from the cart end looks OK- it appears as if the transaction has gone through, it has a transaction ID, no errors or warnings are given that the card is declined or the number is wrong, etc. Yet when the client goes to check on the purchase on the Authorize.net end, the transactions never show up, and the customers CC is never charged. It only happens with this one product. Other products... books, CDs, etc, all go through just fine.

    Does anyone have any ideas of how I can troubleshoot this? I can't figure out what could be happening.

    Does the transaction ID get assigned by SC or Authorize.net?

    Thanks for any help or ideas.

  2. #2
    Squirrelcart Staff Jamie's Avatar
    Join Date
    May 2002
    Posts
    8,118
    Squirrelcart version
    v3.5.0
    The Transaction ID field seen when viewing orders in edit mode is assigned by the gateway. We don't have anything in place that would treat one item differently in terms of payment, so this is very odd.

    Authorize.net does occasionally have a delay in displaying recent transactions. I've received orders that went through but took 5 mins or more to show up in Authorize.net.

    If its been awhile and it doesn't appear, try searching their system for that transaction ID. If you can't find it, you will probably have to call them to find out what is going on.

  3. #3
    Client
    Join Date
    Nov 2009
    Posts
    46
    Squirrelcart version
    not specified!
    Thanks for that info Jamie. That confirms what I thought. It's been several days now, and those transactions have not shown up at Authorize.net, nor has the card holder been charged. Our client even set up a test product for $750, and had the same thing. All the while, other charges go through fine for lower dollar amounts.

    The client has called Authorize.net and they say they have no record of the charge at all. I also asked the client to check and see if may be there were transaction limits, but there are not.

    I'm stumped....

  4. #4
    Squirrelcart Staff Jamie's Avatar
    Join Date
    May 2002
    Posts
    8,118
    Squirrelcart version
    v3.5.0
    There's not much I can do on my end to figure out the cause. If you open a helpdesk ticket, I can confirm whether or not the transaction is actually being sent to Authorize.net for that item. I'll need to know which product you are testing with.

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts