Results 1 to 5 of 5

Thread: Sorting Options / Options Choices Missing

  1. #1
    Client
    Join Date
    Nov 2007
    Posts
    184
    Squirrelcart version
    v3.2.0

    Completed Sorting Options / Options Choices Missing

    Jamie,

    I found another problem. I wanted to change the order of my option choices under the sizes select box.

    Go to the product page in the control panel to sort them
    Click custom to order the options
    Save

    View the product in the cart
    Option text and select box is there, but option choices are missing
    Go back to option and remove br tag under instruction box
    Still not showing

    I added a new test option, unchecked use inventory box and added some choices
    showing okay on product page
    Go back to sort options in the order that I want
    worked fine

    I went back to the control panel to check the size option(the one missing the choices) and somehow the inventory control box was checked so I unchecked it
    Options are showing again.

    I tried reordering another option choice and when I viewed it in the cart, instead of the option choices missing, it took the option text away, so I had to go back in and remove the br tag and it worked fine.

    It seems something is messed up with the use inventory control and options. Also it keeps adding back in the br tag back and checking the inventory control box, after you modify the option.

  2. #2
    Client
    Join Date
    Nov 2007
    Posts
    184
    Squirrelcart version
    v3.2.0
    Quote Originally Posted by wendylady View Post
    Jamie,

    I found another problem. I wanted to change the order of my option choices under the sizes select box.

    Go to the product page in the control panel to sort them
    Click custom to order the options
    Save

    View the product in the cart
    Option text and select box is there, but option choices are missing
    Go back to option and remove br tag under instruction box
    Still not showing

    I added a new test option, unchecked use inventory box and added some choices
    showing okay on product page
    Go back to sort options in the order that I want
    worked fine

    I went back to the control panel to check the size option(the one missing the choices) and somehow the inventory control box was checked so I unchecked it
    Options are showing again.

    I tried reordering another option choice and when I viewed it in the cart, instead of the option choices missing, it took the option text away, so I had to go back in and remove the br tag and it worked fine.

    It seems something is messed up with the use inventory control and options. Also it keeps adding back in the br tag back and checking the inventory control box, after you modify the option.
    It seems to be not only the inventory control, but anytime you modify the option. I just unchecked the required box and it put the br tag back in and the Option text is missing. I removed the br tag again and it's fine now. Hopefully the fix you have works for all of these problems.

  3. #3
    Squirrelcart Staff Jamie's Avatar
    Join Date
    May 2002
    Posts
    7,938
    Squirrelcart version
    v3.5.0
    The thread I referenced earlier discusses the fix for the <br/> tag being inserted. If you enter anything in the Instruction field, it will use that as the option's label, even if it is a space or a <br/>. Lone <br/> tags and &nbsp; entities will be stripped in the final release resolving that problem.

  4. #4
    Client
    Join Date
    Nov 2007
    Posts
    184
    Squirrelcart version
    v3.2.0
    This problem is back in the new version. The br tag is being put back in the instruction area source code, and when I view the product, the text box is missing until I try a couple times to remove the br tag.

  5. #5
    Squirrelcart Staff Jamie's Avatar
    Join Date
    May 2002
    Posts
    7,938
    Squirrelcart version
    v3.5.0
    The <br /> tag is always going to be entered automatically by FCKEditor in the rich text editor fields when you open a record for editing *if* the field is completely blank. The important thing is that when you save that record, Squirrelcart is stripping out that long <br /> tag on save so it is never used.

    I just tested this in v3.0.2 and it is working properly. If you are still having a problem and can reproduce it, open a heldpesk ticket and we can check it out for you.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts